Sign up ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Need: SharePoint permission list - contribute minus the ability to edit page contents (insert/delete new webparts). Also users in this group should be able to add/delete/update documents, create folders, add calender events.

What I have tried so far :

Copied contribute and created a custom permission level (custom sales)

List Permissions (checked items)

  • Manage lists
  • Add Items
  • Edit Items
  • View Items
  • Create Alerts

Site Permissions ( checked items)

  • View Pages
  • Open

Personal Permissions nothing is checked

Still, users in this groups can edit the landing page on the Sales sub-site


  • Contoso site collection ( contoso visitors -- restricted read)
  • Sales Site ( contoso visitors , Sales_custom contribute)

What am I doing wrong?

share|improve this question

3 Answers 3

Put the home page into a document library, break permission inheritance for just that page and set it to read only for members who otherwise have contribute on the rest of the site.

share|improve this answer
Let me try that , Do I have to do that for each subsite eg Sales-CA(subsite)-North(subsite) – Doug Jun 19 '13 at 16:16
@ Teylyn I did try what you had suggested but I ran into issues , so I created a folder named it "sys" and then open SP designer and go to /Sitepages/home.aspx and copy it and past it in the "sys" folder and then right click "Home.aspx" in the sys folder and clicked on " Make This page HOME Page" , so now this new page is the landing page but I cannot control what kind of page that is " Page or published page , webpart page" and I cannot add any webprts to the page – Doug Jun 21 '13 at 19:24
Where did you create a folder? I did not suggest that. Create a library, select an appropriate default content type. Build the page and make it the home page. Don't let SharePoint dictate what page type your home page should be. If YOU want a wiki page, create a wiki page. If YOU want it to be a web part page, create a web part page. Don't try to move the default home page from the site root. That won't work. Create a new page and make that the home page. – teylyn Jun 22 '13 at 3:40
Sorry I created a document library via the browser named it sys – Doug Jun 24 '13 at 3:43
OK, that should work. Create a new page in the document library. You can circumvent all details if you go Site Actions > Site Settings > More options > select Page > Select Web part page. Store the web part page in the "sys" library. Add all the content to it. Then use the ribbon tool to make it the home page or open the site in SPD, select the page and make it the home page. Copying the default home page will not work. – teylyn Jun 24 '13 at 8:51

I ran into similar issues in that when a user has Contribute permissions at a site level, it gives them all sorts of power in some of the oddest places. For me the fix was simple... At the top site level, edit the permissions for each group (not the owner) to remove the Contribute level (thus making them read only to the entire site).

Then you go into each list that you want them to be able to add\edit and turn off Inher. and add back the "Contribute" level just for that list.

This worked great in SP 2010 however in 2013 it does create a bug in a BLOG post where even though the user can edit a post.. the edit menu does not show.

share|improve this answer

What am I doing wrong?

You're using the wrong approach. Instead of creating a new permission level for the whole site, what you're actually trying to accomplish (preventing people from editing specific content) should be accomplished by customizing that content's permission settings.

You don't need to create a whole new library, nor create and set a new home page, as teylyn's answer suggests. (While that approach may also work, it's a much more complicated solution than you need.)

Just go to your existing home page, then in the ribbon's Page menu, in the Manage group, click Page Permissions. On the Page Permissions page, click Stop Inheriting Permissions. Then, for each group that has Contribute permissions at the site level (and that you don't want to be able to edit the home page), check the box next to that group and Edit Permissions† as needed.

Or, if you actually want to prevent editing on all pages (the question title implies only home page), instead of using the Page Permissions button in the Manage group, use the Library Permissions button in the Page Library group.

†Or Remove Permissions, if all members of that group already have Read permissions through membership in another group, e.g., if an "Everyone" group has Read access to the site collection, you can remove the "Contoso Visitors" Contribute permission from the page and leave the "Everyone" Read permission in place.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.