SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to run a workflow on a list where anonymous read/write access is enabled (SP 2010).

The workflow works fine for authenticated users, but fails miserably for anonymous users ("failed to start" message).

I have tried both standard steps and impersonated steps, same result.

I am looking for clues, to see if the issue is specific to my environment, or a general issue with SharePoint.

Thanks!

share|improve this question
up vote 2 down vote accepted

Christophe,

I think I answered by email as well, but in any case, here's a brief blog post that explains how and why:

http://blog.furuknap.net/enabling-declarative-workflows-for-anonymous-users-in-sp20102007

.b

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.