Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I activated "sharepoint publishing infrastructure" feature provisioned by custom web template. I noted, i could not see my custom libraries on QuickLaunch bar. but if i deactivate publishing feature, the libraries are visible on QuickLaunch bar. I have added following feature in my web template:

At WebFeature level, i added following features.

<!--Publishing feature-->
        <Feature ID="22A9EF51-737B-4ff2-9346-694633FE4416" />
        <Feature ID="dffaae84-60ee-413a-9600-1cf431cf0560" />

<Feature ID="541F5F57-C847-4e16-B59A-B31E90E6F9EA">
          <!-- Per-Web Portal Navigation Properties-->
          <Properties xmlns="http://schemas.microsoft.com/sharepoint/">
            <Property Value="true" Key="InheritGlobalNavigation"/>
            <Property Value="true" Key="InheritCurrentNavigation"/>
            <Property Value="true" Key="IncludeSubSites"/>
            <Property Value="true" Key="IncludePages"/>
          </Properties>
        </Feature>

At SiteFeature Level, i added following features.

<!--SharePoint Server Publishing Infrastructure-->
        <Feature ID="f6924d36-2fa8-4f0b-b16d-06b7250180fa" />
        <!-- PublishingPrerequisites -->
        <Feature ID="A392DA98-270B-4e85-9769-04C0FDE267AA" />

What's problem with Navigation ? What should i need to add more ?

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.