SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

So we have a Document Library, and inside the Document Library, we have Document Sets, and inside the Document Sets, we have Documents. No surprise so far, I know. However, when I go into Datasheet View showing Document-level metadata and try to change the value in a field, I get the following error:

"Columns that require data are not included in this view. If you want to edit rows that are missing data in these columns, or add new rows, you must first add the required columns to the view."

However, we have confirmed that all document-level required fields are included in this view. In addition, we've tried everything explained in a ton of online resources, of which apparently I don't have enough reputation points to add here.

...But to make a long story short, absolutely nothing has worked. Any advice about where else we should even start would be extremely helpful. We're pretty much pulling our hair out over here. :(

~CR

share|improve this question
    
Are any of your required field term sets? Those fields are often not editable in the Datasheet view. If so, see what happens if you make them optional? – Dave Paylor Jun 1 '13 at 7:04

I just went through something similar but we were not using document sets.

I made all the columns for the content type I was using optional but kept getting the same error message when I tried to edit a row in datasheet view.

To fix the issue I set "Allow management of content types?" to "No" and saw that a number of columns on the document library were required. I set them all to optional and it worked.

My speculation is that SharePoint only recognizes content types with full fidelity in the standard form view but uses more of the document library attributes / settings in the datasheet view. I haven't seen this documented anywhere but it seems consistent with other behavior that I've seen.

share|improve this answer
    
This fixed the issue for me! I had changed the columns to "Optional" from the "Item" content type management screen, but when I changed"Allow management of content types" to "No," I was able to see those columns were still checked as required fields. I'm not sure why it needed to be changed in both ways, but this was the fix. – Sev09 Jan 21 at 20:23

This occurs when your VIEW is missing one or more mandatory fields from the original LIST.

1) This is a sample LIST. Note we have 2 mandatory fields:

enter image description here

2) This is a view with the 2 mandatory fields, we can add records with no errors:

enter image description here

3) This is a view with only 1 of the mandatory fields:

enter image description here

4) When you try to add a new record in Datsheet View mode, the error appears, as you don't provide the mandatory value to the field MyMandatory2:

enter image description here

The error does not occurs in Standard View because when you add/edit a record, ALL list fields are presented, not only the view fields.

CONCLUSION: You need to put ALL mandatory fields of your list into your view to stop the error.

OR you can review & change the mandatory fields in your list.

share|improve this answer
    
OP clearly stated that the view already includes all the required fields. – Dan Henderson Jun 3 at 15:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.