Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have by mistake copy a master page to test a change and then I set this master page as the default page. But when I try to delete this master page from SharePoint designer I received the following message:-

“One of the selected file can not be deleted because one of these files is currently se as the default or custom Master page for the web site”

enter image description here

And the layout for my publishing site is now corrupted (it have the sharepoint 2013 and 2013 layout combined) as shown below:-

enter image description here

So how I can delete the new master page and aply the old master page again?

BR

share|improve this question

2 Answers 2

Activate the publishing features to get the master page option. Once those features are activared go to the root site set seatlle or Oslo as master and reset all sub sites to inherit the parent master. Once they are applied to all the sites you should be able to delete your copy.

share|improve this answer

Just set one of the valid master pages to be the default and push that change down. Once that has propagated you should be able to delete the corrupt one.

share|improve this answer
    
i already set Oslo.master as the default, but still can not delete the corrupted file and still the layout look awful. –  John Peter May 30 '13 at 15:45
    
and what i have noticed is that the layout is corrupted only on the main site,, while it looks good on its subsites.. –  John Peter May 30 '13 at 15:56
    
do you have it by any change linked to an HTML file -it happens when you work with Design Manager? –  C. Marius - MVP May 30 '13 at 15:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.