Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I am upgrading my SharePoint 2010 sites to SharePoint 2013 by upgrading the database. I followed all the steps as outlined here: http://technet.microsoft.com/en-us/library/jj839719.aspx

My problem comes when upgrading the MySite portion of the site. I have provisioned a separate web app for hosting MySite; where the host and individual sites are different site collections but they are in the same database.

Issue 1: The new MySite host does not resolve when I use SSL in the web app. It partially resolves if I remove SSL.

Issue 2: MySite partially resolves if http is used in web app. Partially, meaning, I see all other profile information in the MySite URL, except photo and List document data.

Please let me know if I am missing or not considering something obvious. Thank you.


Adding more details as I continue tackling this issue:

  1. When I visit the mysite via http, the following information are visible:

    • Account name, Name, Title, Manager, Work e-mail, Work phone, Distinguished name
    • Organization chart information
    • Colleagues

    Other information are not visible such as,

    • Picture, About Me, Ask me about, Career summary, etc.
    • Tags and notes
    • Content (Blogs, Personal and Shared Documents)
    • Membership
  2. I recreated the web app with http binding (default). I then added the https binding for the web app in the IIS. Then I created alternate access mapping with internal url as https://mysiteaddress.dev.company.com and public url for zone as the http://mysiteaddress.dev.company.com

  3. For each database related to the profile services and mysite application, I added the farm and app pool users and granted them db_owner permission (just to check if it works).

  4. Tried creating local SSL certificate and bind it with the site.

None of the above has worked so far.

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.