Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

These are the steps I did under the local administrator:

I go to central admin -> application management -> manage service applications

I click on New-> Business Data Connectivity Service

I enter/select the required fields like name, application pool, application pool identity and click on OK. After a while I see some text that my BDC is created succesfully.

No I see the list with all service applications. When I click on my created BDC service application I got this error:

Error An error occurred. Administrators, see the server log for more information.

Troubleshoot issues with Microsoft SharePoint Foundation.

Correlation ID: 27275209-7fc0-4912-9970-feba5356e9cc

Date and Time: 5/25/2013 9:19:41 PM

In the event viewer I see this error:

The BDC Service application BDC is not accessible. The full exception text is: Access is denied.

Why I get this error? The user which I am logged in is the local administrator and is the site collection owner. BUT I have selected another user account for the application pool for this BDC.

share|improve this question
    
I've noticed on your profile that you have a large number of questions without an accepted answer, even though they have been answered correctly. In order to reward users who took their time to help you and to mark answers as having been helpful to you, please take some time to accept answers on your previous questions. Thank you. –  RJ Cuthbertson Jun 22 '13 at 23:39
    
what are you trying to access?? I think if it's the BDC or the endpoint fx. SQLServer thats the problem. –  Burrhus Jan 11 at 14:59

2 Answers 2

Local Administrator has nothing to do with SharePoint as it has no permissions assigned by default. Furthermore, you should only use Domain accounts when configuring or manipulating SharePoint in any way. Exception could apply, but really not recomanded at all.

You would need to use your Farm Administrator and under Service Applications locate the BCS Service application and change security of the respective BDC Model (you might have more if you deployed multiple, choose appropriate one) as deployed in SharePoint and allow respective users (again - domain users) to Execute, Read, etc.

Tried something similar to these steps http://blogs.msdn.com/b/ericwhite/archive/2010/06/11/access-denied-by-business-data-connectivity.aspx ?

share|improve this answer
    
I logged in with the farm account, removed the old bcs service application and created a new one. I have the same problem. I have also add some users into the permissions settings and give them full control. Still have the same problem. Please help?? –  KHA May 26 '13 at 11:33
    
Does the BCS Service is started on the "Services on Server" page in Central Admin? –  Alex Choroshin May 26 '13 at 22:57
    
Alex - if he can deploy/configure entities it should be already properly started otherwise it would be impossible to deploy, right? –  C. Marius - MVP May 27 '13 at 15:14
    
could you check under SP-CA > Security > Manage Service Accounts and make sure you are not using the Local Administrator by any chance elsewhere too?? Is at least the Farm Administrator able to access the definition? What is your source connecting too?? –  C. Marius - MVP May 27 '13 at 15:17

Your error could be because the authentication methods that were allowed on the SecureTokenServiceApplication IIS web application were not correct so Please check this great article, I think you could find here your solution:

http://johnnyharbieh.wordpress.com/2012/09/19/event-id-8085-business-data-connectivity-service-application-is-not-accessible/

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.