Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I've created a custom Web Part dedicated to displaying swf content. It uses swfobject and jquery to serve and display the flash file.

If the SWF is placed in a Document Library (/Documents/test.swf), the flash file will not load. It appears that the size (width and height) is detected, but the flash file doesn't load or play.

Alternatively, if the SWF is served from the file system (/_CONTROLTEMPLATES/FlashTest/test.swf) OR from an external site the flash serves, displays, loads and plays just fine.

I have turned on Permissive Browser File Handling for the Web Application with no effect.

share|improve this question
add comment

4 Answers 4

up vote 1 down vote accepted

There's nothing off the top of my head that would prevent it from loading, assuming the user has the appropriate permissions to the library. You mentioned that you're using swfobject to load it, which I've had a lot of success with in SP2010.

You might try putting the SWF in the Style Library or some other location within the site to try and pin it down, it sounds like permissions to me. The size is specified in the swfobject call, so it's not necessarily getting the size from the SWF itself, but rather from the swfobject call; which just means it's writing the object tags, not necessarily accessing the SWF.

share|improve this answer
add comment

There is a better way to handle "Browser File Handle" issue. Take a look at my blog here: http://www.pdfsharepoint.com/sharepoint-2010-and-pdf-integration-series-part-1/

Solution #2 addresses Pdf extension without exposing entire Web Application to "Permissive" browsing. Setting "Browsing File Handle" to "permissive" opens too many vulnerabilities with other file extensions.

Thanks,

Dmitry

share|improve this answer
add comment

Not sure how your web part is created, but it appears that someone else tried to do the same thing with some success.

http://www.codeproject.com/KB/sharepoint/MOSSFlashWebPart.aspx

Take a look, it may help.

share|improve this answer
add comment

By default, Sharepoint 2010 is blocking the ability to open HTML (swf) documents directly from a document library.

However this can be changed by adjusting the browser file handling option. The option is located here:

  1. Central Admin\Application Management\Manage Web Applications.
  2. Select General Settings for the specified web application
  3. For Browser file handling, select permissive. The default is strict​

I have found answer here: http://paritala-sasi.blogspot.com/2009/12/opening-html-files-in-sharepoint-2010.html

share|improve this answer
    
Sorry szpilla, but in my original question I explicitly said that I had already done this. This isn't the problem. –  blackf0rk Nov 26 '10 at 14:35
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.