Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I ran a stsadm -o enumsites and received 2 error messages in the output. It generates the error: The system cannot find the path specified. (Exception from HRESULT: 0x80070003). I know the URL of one of the site collections from doing some web part testing.

I cannot trace down the other site collection. enumallwebs shows nothing for the one collection I know of. The sites do not show up as orphaned.

I'm at a loss as to how to identify these sites and remove them from the configuration database I presume.

share|improve this question
    
I've tried everything in this MSDN post and the issue still persists, the symptoms seem identical. social.technet.microsoft.com/Forums/en-US/sharepointgeneral/… –  PirateEric Nov 23 '10 at 19:20

3 Answers 3

up vote 1 down vote accepted

Ok, I found out what the issue was. The site was a particularly large site restore that was deleted from the web ui in our test farm. I believe the delete timed out and left a bit of bad data hanging out in the SiteMap table.

This blog post lead me to finding where the particular site collection was located. Once I had that content database isolated, I deleted it from Central Administration and and added it back into the farm as described here. This cleaned up the corrupted sites.

share|improve this answer

What happens if you write a console app to iterate through the site collections? Could try identifying and removing it that way...

share|improve this answer
    
I don't any C# to do that, I'm not a dev by trade. –  PirateEric Nov 9 '10 at 17:45

Due to abrupt power off situation, restarting error can lead the SharePoint server or the SharePoint sites to get errors. Sudden error that can be found you need to make use of the professional repair tool MS SharePoint Repair Tool which is capable of repairing any sort of corruption, damaged or inaccessible issue in your SharePoint server and sites. It can easily repair and restore the corrupted database in a new healthy form.

For More Information: http://sharepoint.filerepairtool.net/blog/sharepoint-2010-corruption-content-database

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.