Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have created a Enterprise Wiki site collection , then i tried to define a term store for it, but when I go to ---> Site Settings----> Term Store Management. I got the following error:-

The Managed Metadata Service or Connection is currently not available. The Application Pool or Managed Metadata Web Service may not have been started. Please Contact your Administrator.

Baring in mind that i have enabled the "Managed Metadata Web Service" service and i am the site collection administrator ?

share|improve this question

2 Answers 2

The Managed Metadata service application is a different entity and it contains its own database as well. This has its own Users managing provision. Even though you are the Site collection administrator might be you dont have permissions to access managed metadata db.

You can have grant the permissions in two levels, when you select the Managed Metadata Service Application on the Ribbon you can Permissions and Administrators Options.

Depending upon your requirement, add the user and grant accordingly.

If still you see the issue, please select the proxy of the Managed metadata service application and in the ribbon Click on the properties tab. It opens a popup and select the check box"This service application is the default storage location for column specific term sets."

Make sure after do any operation above, wait for some time to reflect the changes. As in the backend it requires to run OOB timer jobs to effect the service application.

share|improve this answer

please do the following steps

  1. Make sure the service "Managed Metadata Web Service" is started at [Central Admin >> System Settings >> Manage services on server]. If it is not started just start it and wait for some time to get the Service application to take the affect.
  2. Make sure the check box "This service application is the default storage location for column specific term sets." is checked at [Central Admin >> Application Management >> Manage service Applications >> Managed Metadata Service Application Proxy >> Select it and click on Properties on ribbon]
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.