Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Cannot submit new posts to a MySites Newsfeed or to a MicroBlog on a Team Site in SharePoint 2013.

"SharePoint returned the following error:

Unexpected response from server. The status code of response is '500'.

The status text of response is 'System.ServiceModel.ServiceActivationException'.

ontact your system administrator for help in resolving this problem."

Any ideas? I didn't find anything useful in the USL files yet!

share|improve this question
add comment

1 Answer

I will try and make this answer not as vauge as the question posted and the error message given by Sharepoint 2013.

I found that there were two issues related to adding new posts to a newsfeed or microblog.

1. A hidden feature had to be activated on the site

[Enable-SPFeature -Identity 6928B0E5-5707-46a1-AE16-D6E52522D52B -Url http://intranet/sites/TestNewsfeed]

2. Add permissions for service account user to access user profile data

  1. Open Central Administration, then
  2. Manage Service Applications
  3. Highlight the User Profile service application link, but don’t click it link! Click on the whitepace with no text. Microsoft have made these links context aware!!
  4. In the “Sharing” group of the ribbon, click “Permissions”

Permissions

  1. In this prompt, put in your service account that is running your Distributed Cache, and grant it full control.

Add account

Last thing to consider is that performing this action may cause the User Profile Services web services to be restarted, if the farm is in use then perform steps after hours.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.