Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I'm trying to add some directories from my file server to be included in the search centre in sharepoint 2013. I have added a new content source to be crawled and stated it is a file server. I filled in the path \fileserver\test After doing a full crawl i get this errer :

Access is denied. Verify that either the Default Content Access Account has access to this
repository, or add a crawl rule to crawl this repository. If the repository being crawled 
is a     SharePoint repository, verify that the account you are using has "Full Read" 
permissions on the SharePoint Web Application being crawled.

I don't have any clue how to fix this error, i'm very new to SharePoint.

Thanks !

Kevin

share|improve this question

2 Answers 2

The user account that operates the search crawling has to be given read permission to the file share you wish to crawl.

share|improve this answer
    
How do I find which account this is? –  Vandoorn Kevin May 14 '13 at 6:09
    
In central admin, manage service applications, Search Service. It will be the Default content access account. –  PirateEric May 14 '13 at 14:58
    
my default content acces account is NT AUTHORITY\NETWORK SERVICE but how do I give this account full read permissions? –  Vandoorn Kevin May 16 '13 at 7:13
2  
A dedicated user account is preferred. What happens if you leave the company? Now search is hosed because it's running as you. –  PirateEric May 16 '13 at 15:05
1  
I will try to add an account to the AD named SPSearch and set that account as the default content access account so there won't be any trouble in the future. –  Vandoorn Kevin May 17 '13 at 6:16
up vote 0 down vote accepted

Changed the default content access account to my user account. Everything works fine now !

share|improve this answer
1  
So PirateEric's answer is the correct one, and not this one. Right? –  Robert Lindgren May 16 '13 at 8:36
    
No it's not... I can't add the NT Authority\network service to the folder if you noticed that in my posts...... i CHANGED the default content access account to my account not what he suggested... –  Vandoorn Kevin May 16 '13 at 8:48
    
Well that just seems like a hack for not having configured a correct default access account to me –  Robert Lindgren May 16 '13 at 8:50
    
didn't configure anything... was the default option... –  Vandoorn Kevin May 16 '13 at 8:51
1  
Check this link blogs.msdn.com/b/ijasari/archive/2011/04/15/… but skip the two "Enable.." headings since they are for anonymous access sites (I know it's 2010, but it is kind of the same story in 2013) –  Robert Lindgren May 16 '13 at 9:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.