Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I am new to sharepoint workflow development.

I created my workflow in sharepoint designer 2010. My problem is the following:

My workflow has a few steps, in every step I use the "collect data from user" action to get necessary data from user.

It has worked two or three days properly but now when this action creates a task in tasklist and the user collect the task and press "complete task" button my workflow crashes.

I am writing log messages after every workflow action and condition and all worked properly except the "collect data from user" action. After pressing "complete task" my task status is "in progress" but before, when the workflow worked properly, it was "completed".

I hav tried: Use default form (not custom forms). I removed the collect action and add a new again, but the error is same. And this problem was in every collect action in this workflow / list (if I skip the first collect action, then the error occurred in the next collect action).

I also try delete list and workflow and rebuild all. (it worked but after few days error occurred again).

History list for the workflow only log this about the error:

5/7/2013 2:10 PM Error System Account An error has occurred in (workflow name).

P.S my associated list contains about 90 columns (I don't know this is important or not)

If someone have had the same proplem, or have any idea about how to resolve this error please help me.

share|improve this question
    
After three days were there any changes to the List definition or structure? –  user851316 May 8 '13 at 9:15
    
No, the list definition and structure is same. I only add send email action to workflow. I removed the email send action but the error is same. –  uh15 May 8 '13 at 10:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.