Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

This may be a duplicate, because this error is pretty common in every part of sharepoint. However, the search function didn't find anything for my particular problem.

To the problem: I have a List template which I want to use on a subsite. Creating the list and adding items works wonderful. Here is the list, which I'm talking about:

The evil list Now the problem, when I click on a list item, for detail view or edit mode, it runs into a

NullReferenceException: Object reference not set to an instance of an object.

exception. Here a picture of the error: Error message

So, the funny thing is, when I get the list items via VS everything works fine and it receives the listitems as expected. See this picture:

received list items via vs

And as mentioned above, the list items are visible in the list itself. This error only occurs if you click on an item in the list.

Does anyone know, how to solf this issue?

thanks so far. J├╝rgen

Edit:

Content type in request: IE

In sharepoint designer: SPD

share|improve this question
    
What is ContentTypeId parameter in the request to EditForm.aspx/DisplayForm.aspx? –  Andrew May 7 '13 at 9:52
    
Also, does your list template contain content types? –  Andrew May 7 '13 at 9:57
    
I looked it up, the manifest of the list template does not contain the conent type id of any of those conents. However, there are some declared but no exact ids: ContentTypeID="0x" this is several times. And the request id is the same. see edit in post –  Jürgen Stürmer May 7 '13 at 10:42
    
Could you provide your list template? –  Andrew May 7 '13 at 11:23
    
sure: wikisend.com/download/365716/Idea List.cab –  Jürgen Stürmer May 7 '13 at 11:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.