Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

If I change the locale under regional settings in SharePoint 2010, I get an exception like this:

The column "column1" in the list or library "list1" has been marked for indexing. Please turn off all indexed columns before changing the collation of this site. You may re-index those columns after the collation of the site has been changed.

The issue can be solved by navigating to the list settings, removing the indexed column and trying it again. After the successful change of the locale setting i have to set all the columns indexed again.

But if i try the same (on the same web) using powershell:

$culture = [System.Globalization.CultureInfo]::CreateSpecificCulture(“sv-SE”)
$spWeb = Get-SPWeb http://someurl
$spWeb.Locale = $culture
$spWeb.Update()
$spWeb.Dispose()

The locale can be changed without any problems regarding indexed columns. My question is:

Does the second way take care of the indexed columns by itself? Or do i have to expect trouble because the powershell doesnt take care of them?

Here some information i already gathered:

http://just-a-programmer.com/post/2013/05/08/SharePoint-2010-Indexed-columns-and-changing-the-locale-setting

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.