Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I'm hoping you can help me out with a problem I'm experiencing. I have developed a custom site definition. The site contains 2 document libraries (Correspondence and Documents) and a list (Records). The site deploys and works perfectly on my development server.

I then deployed the site definition on to the production server. When I attempt to create a site of this type it fails. The ULS logs show me that one line appeared to be causing the problem -

No document templates uploaded for list Correspondence - none found for list template 121.

At this point I decided to remove the DocumentTemplate="121" (I read this was optional and unused) attribute from the ListTemplate node in the elements.xml file.

After re-deploying to the production server I now got -

No document templates uploaded for list "$Resources:core,MasterPageGallery;" -- none found for list template "100".

Reading up on this a few people have had this issue and have managed to fix it by activating the SharePoint Server Publishing Infrastructure feature. Firstly, this featur is not activated on my dev server and there are no problems. Secondly, when I tried to activate the feature on my production server, another error occurred (which also did not when I tried it on dev).

The critical line in the ULS logs (there were too many other messages to post - I can if required) was -

Event log message was: 'Failed to provision role definitions.'. Exception was: 'System.ArgumentException: Value does not fall within the expected range.

I really feel out of my depth here so hopefully someone can help.

Thanks in advance

Zak

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.