Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have done an upgrade for a SharePoint 2010 site collection to 2013. The site collection in question is a document center and there were a few thousand documents contained in it. Another person recently pointed out the Document ID search was not working, so I investigated and found that the links for each document's ID were still referencing the original SharePoint 2010 server, not the new server. I attempted to assign new document ID's to the documents using the library settings but that did not do anything. I also deactivated and reactivated the Document ID service feature on the site collection, to no avail. How can I get this to match the current location?

share|improve this question
    
Out of interest: Are you using a custom document ID provider / have customized the document ID or is it still SharePoint Standard? –  Dennis G May 6 '13 at 15:32
    
it's OOB document ID functionality –  Matt May 6 '13 at 17:07

1 Answer 1

up vote 2 down vote accepted

The document IDs are assigned and updated based on a timer job. If deactivating and then activities the job did not update the Document IDs with the new path and info, I would focus on reviewing the status and result of the Timer Jobs. Please note that these jobs run daily by default, though they should also be triggered by the activation process. If they have not run, then I would manually run them.

The two jobs you are looking for are:

  • Document ID assignment Work item that assigns document ID to all items in the site collection. Daily
  • Document ID enable/disable Work item that propagates content type changes across all sites when the Document ID feature is reconfigured. Daily
share|improve this answer
1  
Manually running these timer jobs seemed to do the trick! I spot checked some documents and they all had the newer IDs. –  Matt May 6 '13 at 17:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.