Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have a new article page that I created but the only field I can see when editing is the Title field. There is no page content field being shown. Why is this so? I have another sharepoint farm that I tested and the page content field shows up fine on an article page?

share|improve this question

1 Answer 1

Use SharePoint Designer to edit the page layout and ensure that the fields you want to populate are present in the layout. Use an out of the box page layout as a guide.

All controls inside the <ContentTemplate> tag will show on the page in view and in edit mode. To hide controls in view mode, wrap them in a <PublishingWebControls:EditModePanel> tag.

Save, check in and publish.

share|improve this answer
    
Thanks for the help, I am using an OOTB page layout so shouldn't it have the appropriate controls already? –  binga30 May 3 '13 at 0:00
    
Has the site/library been configured correctly? Which page layouts are available to the site? Check Site settings > Page Layout and Site Template Settings and make sure the desired page layout is listed there. Then go back to the page and confirm that you can switch between different page layouts. Do any of these show any content? –  teylyn May 3 '13 at 0:07
    
This is a default Team Site, with the publishing features enabled. All page layouts are available and I can select any of them, but no the Page Content field is not showing on any of the page layouts when trying to edit the page. –  binga30 May 3 '13 at 0:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.