Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I followed this tutorial to enable counts on sharepoint 2013 on a Enterprise Search Center site

http://blogs.technet.com/b/searchguys/archive/2012/08/16/getting-refiner-counts-back-in-sharepoint-2013-search.aspx

Counts are displayed but they are not accurate.

For example, for refiner "Languages" with "en" value it shows 29 documents but when I refine by "en" it shows 53 documents.

Any ideas why is this happening? Is this a Sharepoint bug ?

See this image: wrong counts

share|improve this question
    
Any luck with correcting the counts? Was the solution to run a full crawl as suggested by DrFeelgood? –  Mark Oct 3 '13 at 14:57
    
No, we implemented our own web part to correct this, requesting refiners using REST api will give the right counts. –  Bogdan M. Oct 3 '13 at 17:20
add comment

2 Answers 2

When was the last time you ran a full crawl since this issue? I'll be clear, I don't think that's the issue but managed properties (the refiners) are very unique and a full crawl is needed before you can even search against them. I wouldn't be half-surprised, as unbelievable as it sounds, that you would need to do a full crawl for the refiners to show the correct amounts. Perhaps that's why Microsoft doesn't show them by default. The managed properties may only be pulling items from the last full crawl index.

Aside from that, could you post your search display template that shows the number as well as let us know what types of searches you are running?

share|improve this answer
add comment

Are you using FAST Search?

If you aren't then I am pretty sure the numbers are actually estimated. This is due to the fact that the refinement panel doesn't look at the whole set of results to get the counts.

I encountered the same problem when setting up a refinment panel and ultimately decided not to use the counts due to the inaccuracy, if someone knows of another solution i'd love to know as well.

share|improve this answer
    
It is Enterprise Search Center –  Bogdan M. May 1 '13 at 12:31
    
Isn't FAST supposed to be the default search engine for SP2013? –  Robert Lindgren May 1 '13 at 12:59
    
I didn't realize it was 2013 when I posted this... my fault. –  BlueBird May 1 '13 at 16:06
    
No problem, easy to miss. And for the record, it was not me that downvoted you –  Robert Lindgren May 1 '13 at 16:23
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.