Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Has anybody successfully managed to remove the exasperating notice that appears at the top of OSX Chrome everytime you load a page in SP?

It says "Could not load Sharepoint Browser plugin"

It's not fixed by disabling the presence feature like many claim - I'm thinking this is a master page fix, bit not sure where to start.

Any guidance would be brilliant.

share|improve this question
    
Please be sure to add SharePoint version information. SP Enterprise 2010? –  Robert Kaucher Jun 2 '13 at 1:20
add comment

2 Answers

Google dropped support for QuickDraw and Carbon NPAPI models in Chrome 22+, so plugins that doesn't negotiate modern models will no longer load.

The best you can do at the moment is to disable the plugin on your browser.

  1. Type about:plugins or chrome://plugins/ in the address bar
  2. Find the SharePoint Browser Plug-in - Version: 14.x and disable it

enter image description here

I haven't found anything that doesn't seem to work so far

share|improve this answer
add comment

Try removing the part of the code in the master page that contains the Active X control. I'm sorry, I don't have a master-page in front of me and I'm not even sure which version of SharePoint you are running to begin to help you find where that section of code lives.

To be completely honest, I doubt the majority of SharePoint developers have even tested SharePoint out on a Mac.

share|improve this answer
    
Hi, Thanks for the reply. Yes I'm getting that feeling about MAC uptake. I've been working with the master page for some time, no obvious place where the control is rendered. Years ago when SP was first launched, it used to be simple to disable the presence facility - these days, not so. Running 2013 - almost a brilliant product, let down by these silly browser issues. –  CCDW May 1 '13 at 14:17
    
Are you using a custom master page? If not, try using the minimal master page that can be created through Design Manager. See if that solves the issue. If so, I'd build a design around that. Of course, I've had some weird issues with minimal design pages (especially with third party tools that expect content placeholders) and you need some certain Classes/IDs like id="s4-workspace" class="ms-core-overlay" and s4-bodyContainer to get the ribbon to work properly I've found. –  EHorodyski May 1 '13 at 15:57
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.