Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I could not automatically logged into sharepoint site with the window user account. I have to click "SignIn" button displayed on the right of the screen.(as shown in picture) enter image description here

As described in this link ( http://blogs.kma-llc.net/microknowledge/2011/03/configuring-internet-explorer-for-automatic-sharepoint-login.html), I configured Internet explorere settings by:

1.  add site url in local intranet 
2. and set user authentication to "Automatic logon with current user name and password"

But I still get this SignIn button instead of my window user id.

Do I need to do any configuration at Central Administrator?

share|improve this question
4  
What authentication mode and provider are you using? Is the site configured for anonymous access? –  Mike Oryszak Apr 30 '13 at 15:07
    
Yes, Anonymous access is enabled, is that causing problem? –  Rohita Khatiwada May 1 '13 at 8:38
    
@RohitaKhatiwada is your server is in development environment and what you actually trying to achieve ? do you want to give everyone access to the site without login or you just want it for yourself on your machine only ? –  Muhammad Raja May 1 '13 at 17:59
    
Yes, Currently I am working in a development server.But in future we are going to use production server so that all external users can access our site. Therefore I need to enable annymous user to let them access our site without requiring them to login. –  Rohita Khatiwada May 2 '13 at 11:12
    
Can you confirm, if you followed all of steps in this article, topsharepoint.com/enable-anonymous-access-in-sharepoint-2010 –  Muhammad Raja May 2 '13 at 18:01
show 1 more comment

4 Answers 4

up vote 4 down vote accepted

Do I need to do any configuration at Central Administrator?

If you want it just for your personal machine then you shouldn't touch CA.

You need to perform some additional steps, e.g. creating a group policy and modifying IE Enhanced Security Configuration.

Follow this article out,

How do I make our SharePoint site stop asking me to login? – Part I

How do I make our SharePoint site stop asking me to login? – Part II

Update

Since you want anonymous access for all user's follow this post but just to let you know you will need to make changes to Web Application through CA,

Enable Anonymous Access in SharePoint 2010

share|improve this answer
add comment

It seems you're logging in with URL that is being configured for Internet (alternate access mapping) aka anonymous access. Can you check if the URL is correct? Are you extending the Web application for anonymous access?

share|improve this answer
1  
Url is correct. But Annonymous accesss is enabled. Is that causing problem? –  Rohita Khatiwada May 1 '13 at 8:43
add comment

Also if this is a local machine, you might have to add your machine to the local intranet sites so that Windows Authentication works correctly.

share|improve this answer
add comment

Since this seems to be an anonymous site it will not auto log you in. I was able to "fix" this by using some custom code. My solution is outlined on my blog here: http://steve.thelineberrys.com/ntlm-login-with-anonymous-fallback-2/

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.