Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have a workflow, which is set to run when an item in a list is created. The list is email enabled, and is populated only by email.

When I send an email to the list, the workflow is not started - however if I create a new item in the list through SP the workflow starts and runs.

My environment is SP 2010 using Nintex Workflow.

This appears to be a well known problem in WSS, but I can't find anything for SP 2010 specifically.

share|improve this question
    
I am in the same situation, has anyone come up with a solution for triggering a workflow off an email to an email enabled SharePoint library? thanks! –  user4080 Jul 11 '11 at 21:31
    
Are you able to reproduce this issue without using Nintex Workflow? Questions about third party products are off topic here (see our faq). –  Alex Angas Jul 29 '11 at 0:44
    
This is reproducible with standard SP workflow also. –  Darbio Aug 1 '11 at 4:36
    
Please give more information, maybe you are having issues regarding mail server. –  Thuan Aug 28 '11 at 8:06
    
Try to find more information from sharepoint logs. Go to the %programfiles%\Common Files\Microsoft Shared\Web Server Extensions\14\LOGS folder, looks at the logs files (unfortunately there are a lot of files with a lot information) and find in this files logs lines with type Workflow Infrastructure –  MishaU Oct 27 '11 at 11:08

6 Answers 6

up vote 4 down vote accepted

You have to change a system setting that allows workflows to run when emails are received in an email-enabled doc lib. Other than this, System Account is not allowed to run workflows for security purposes. It will only work when an email is received, not when an item is edited by System Account. You should not be editing items with the System Account:

stsadm.exe –o setproperty –propertyname declarativeworkflowautostartonemailenabled –propertyvalue yes

See complete article: Workflow not running with system account login?.

share|improve this answer
    
I may have upvoted prematurely. My net admin tried running the command pasted above but it did work. He used the one found here: support.microsoft.com/kb/953289 (we are running SharePoint Foundation) –  bkwdesign Jan 15 '13 at 18:16
    
This did not solve my issue. However, using Patricia Smith's answer solved it for me. sharepoint.stackexchange.com/a/58658/2989 –  Nathan DeWitt Feb 26 at 15:32

I have a workaround for this issue that does not require any SharePoint farm changes.

  1. In the email-enabled document library or list, create a custom text column that has a default value.

  2. In Nintex workflow, set it to trigger on item changed - conditional. Make the condition the column/value you set in step 1. You should also have the workflow change that value to something else as one of the activities.

This seems to bypass the issue with the system account not being able to launch a workflow triggered by a new emailed item. The trigger is no longer the new item, but the creation of that custom column.

share|improve this answer
    
This worked for me when the stsadm command did not. –  Nathan DeWitt Feb 26 at 15:31

Have you tried following the instructions you found for WSS? This is Microsoft's official KB article about it.

More on Google.

share|improve this answer
    
Yeah I have tried this, but the commands/properties suggested in the MSDN KB do not apply for SP 2010. –  Darbio Nov 2 '10 at 23:10

Can you tell me how the emails are created in the list? Basically with which account? Try to create emails into the list using users other than system account who has permission to create items in the list. SharePoint workflows do not start automatically while items are created using system account.

share|improve this answer
    
thanks Deepu - I will look into this and let you know. –  Darbio Oct 28 '11 at 2:50

I'm kinda reposting my comment from @Jimbo Alva's answer. Again, tested to work on SPF 2010 (taken from the KB article link posted by @Muhimbi)

stsadm -o setproperty -pn declarativeworkflowautostartonemailenabled -pv true
share|improve this answer

take a look at this article:

http://social.technet.microsoft.com/wiki/contents/articles/4607.workflows-on-incoming-emails-in-sharepoint-documents-library.aspx

Regard, Megren

share|improve this answer
    
While this may theoretically answer the question, we prefer inclusion of the essential parts of the answer here, and to provide the link for reference. See answer for general guidelines. [mod] –  SPDoctor Feb 2 '13 at 16:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.