Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I'm trying to activate a web level feature using powershell with the following command:

Enable-SPFeature –identity 3ad4787b-e859-432c-be22-c772725e0dbc -URL http://win-p8f03cpnjn5:5555/gateway/home/stafftravel/

I get the following error

The Feature is not a Farm Level Feature and is not found in a Site level defined by the Url

However I can see the feature in site settings/site feature page.

This commands works well for site collection features but fails on web scope activation.

Any idea what am I missing?

share|improve this question
add comment

3 Answers

make sure you can see the file in 14 hive and that your using the correct guid/url!

14/Template/Features

9 times out of 10 its the wrong guid or spelt incorrectly ;) / wrong url

share|improve this answer
add comment

You need to make sure the feature (solution) is really developed for Farm level scope. If that is a WSP file, you can rename it to .cab and extract it and check the "Scope" attribute in Feature.xml. enter image description here

share|improve this answer
add comment

Make sure you have installed the feature successfully on the farm before enabling it. This will remove this error.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.