Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

App Management Service & Microsoft Sharepoint Foundation Subscription Service are running but it still shows error as follows.
Error message :

Settings or services required to complete this request are not currently available. Try this operation again later. If the problem persists, contact your administrator.

Error in sharepoint log viewer :

Microsoft.SharePoint.SPException: Settings or services required to complete this request are not currently available. Try this operation again later. If the problem persists, contact your administrator.

at Microsoft.SharePoint.SPSubscriptionSettingsServiceApplicationProxy.ProcessCommonExceptions(Exception ex, SPServiceLoadBalancerContext context) at Microsoft.SharePoint.SPSubscriptionSettingsServiceApplicationProxy.ExecuteOnChannel(CodeBlock codeBlock) at Microsoft.SharePoint.SPSubscriptionSettingsServiceApplicationProxy.GetSubscriptionMetadata(Guid subscriptionId) at Microsoft.SharePoint.SPSiteSubscriptionSettingsManager.GetMetadata(SPSiteSubscriptionIdentifier subscriptionIdentifier) at Microsoft.SharePoint.ApplicationPages.ConfigureAppSettingsPage.OnLoad(EventArgs e) at System.Web.UI.Control.LoadRecursive() at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

share|improve this question
    
I also faced the same issue after i reboot the server. when i try to access Setup APP URL always shows Settings or services required to complete this request are not currently available. Try this operation again later. If the problem persists, contact your administrator. could you give me some advise thanks/ –  user24010 Feb 27 at 9:06

2 Answers 2

This error is due one of the service application not running in your machine.

1.App Management Service Application 2.Microsoft SharePoint Foundation Subscription Settings Service Application 3.Managed Metadata Service

This should resolve the issue, because just now i resolved the issue in my Dev environment.

share|improve this answer

you need to give permissions to the App Management Service Application and Microsoft SharePoint Foundation Subscription Settings Service Application

Select the App Management Service Application--> Permissions in the Ribbon add the user name

Select the Subscription Settings Service Application--> Permissions in the Ribbon add the user name

and now go to CA --> APPS --> Configure App URLs

that did the trick for me .....

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.