Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

When I grant permissions on anything, site, list, etc., in SharePoint 2013 I don't see the ability to opt out of sending an email to the user being added. The only option I see is the group or permission level drop down.

Has it been removed from 2013 or do I not have something set up correctly? For the time being, I removed the outgoing email settings but that is not valid solution.

enter image description here

share|improve this question

2 Answers 2

up vote 5 down vote accepted

When you add a user / group in SharePoint, you should see "Send an email invitation" check box to control whether or not send the welcome e-mail to the new users. You could clear that check box and it should fix your problem.

enter image description here


Also, there are some situations when "Send an email invitation" is hidden. I checked dialog's code-behind by reflector and find that:

Part of InitPage method of AclInv.cs:

if (isEmailServerSet)
  {
    if (object.get_IsCompatibilityLevel15Up())
    {
      this.PanelSendEmail.Visible = true;
      this.PanelEmailBody.Visible = true;
      this.txtEmailSubject.Text = SPResource.GetString(CultureInfo.CurrentCulture, "ACLInviteDefaultSubject", (object) this.Web.CurrentUser.Name, (object) this.TargetObjectTitle);
      if (this.CanSendLink)
      {
        this.PanelRequireSignIn.Visible = true;
        this.InitRequireSignInLabel();
      }
      this.peoplePicker.set_VisibleSuggestions(5);
    }
    else
      this.ifsSendEmail.Visible = true;
  }

As you can see sharepoint checks "isEmailServerSet" before setting visibility to inviation configuration panels.

As the result, you need to configure outgoing e-mail settings in CA (Central Administration -> System settings -> Configure outgoing e-mail settings) to make invitation configuration visible in "Share" dialog.

share|improve this answer
    
Thanks for the response but I don't have those options. Here is a picture of what I am seeing. i34.tinypic.com/2rmt6s9.png –  brian.quick Apr 25 '13 at 21:19
    
I updated my answer. Hope it will help. –  Andrew Apr 26 '13 at 8:51
    
Thanks. I added the outgoing email settings again and recycled to app pool and the options are showing now. Not sure what the issue was...probably user error. –  brian.quick Apr 26 '13 at 14:00

Are you using foundation by any chance ? I cant check personally at the moment. But this is just the sort of thing that Microsoft would randomly remove from foundation.

Fyi i get the same as Andrew in Server and 365

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.