Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have a main sharepoint site configured with some Navigation menu items. I have also have a MYSite. The same Navigation menu items are shared between both the main site and my site. But the navigation from mysite to Main is not working. Please let me know how do I give the links from my site to mainsite.

share|improve this question
    
If they have the same navigation, how is the link not working? Are you getting an error? Sending to the wrong page? What happens? –  David Lozzi Apr 25 '13 at 14:30
    
Top the top menu is configured to display as same but not the links to those pages.This means it uses the same master page. –  Ram Apr 25 '13 at 14:50
    
So when a user clicks on the link back to the main site, what happens? –  David Lozzi Apr 25 '13 at 14:54
    
It is taking the relative path of the mysite and appending the string of the actual relative path of the main site. –  Ram Apr 25 '13 at 15:34

1 Answer 1

If the home link is part of the master page, can you change the link to be a full url instead of a relative url? If not, you can use some Javascript to update the link to include the full site url instead of a relative url.

share|improve this answer
    
Thanks David. I will do this. Many thanks for your help. –  Ram Apr 26 '13 at 14:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.