SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a CAML query of the form shown below which is called via the Sharepoint web service interface to search the entire Sharepoint site containing 600,000 documents looking for documents:

<Query><Where><Contains><FieldRef Name="References_x0020_which_x0020_can_x0020_view" /><Value Type="Text">A00000</Value></Contains></Where></Query>

The Query options I use are:

<QueryOptions><ViewAttributes Scope="Recursive" /><IncludeMandatoryColumns>False</IncludeMandatoryColumns></QueryOptions>

where A00000 is a reference number (of which we have 80,0000). This works fine in Sharepoint 2007 but breaks the 5,000 item limit in Sharepoint 2010. Any thoughts on how to improve the search?

share|improve this question
Are you saying the query returns 80000 items, or that there are 80000 reference numbers? – Stuart Pegg Apr 23 '13 at 11:14

My team recently faced the same problem about the 5k limit in SP2010. The only difference was that we were querying with Lookup columns. So after tons of research and try-this examples, this article helped a lot: So if you can use the ID equivalent instead of the value, I think it could help. Changing the default limit is the easiest you can do and also the most popular response to the problem, but this should not be the case, and most of all - it is temporary and not a good practice.

Hope this helps!

share|improve this answer

I encountered the same issue and found a few cases where I was able to get around the limitation by using the ID field in the filter. Look here:


share|improve this answer

Resource Throttling "List View Threshold" property limits the maximum number of items that a database operation can involve at one time. It is 5000 by default. You can change it in:

Central Administration -> Manage Web Applications -> Select WebApp -> General Settings/Resource Throttling -> Change "List View Threshold".

share|improve this answer
Please don't post answers in bulk. You have posted the identical answer to and – SPDoctor Apr 23 '13 at 19:09

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.