Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Every time I click on a excel file I am receiving a popup message mentioning -

We're sorry. We ran into a problem completing your request

MS Word is working fine though.

I performed all the steps mentioned in the below given articles:

Am I missing anything?

share|improve this question

2 Answers 2

up vote 4 down vote accepted

I found the solution.. This is what I did -

Navigate to Document Library -> Library Settings -> Advanced Settings -> and changed the 'Default open behavior for browser-enabled documents:' to 'Open in the client application'.

and Excel sheets worked smooth :)!

I tried the same issue on another server without enabling the excel services and all the other saga (two links mentioned in my question) and it worked fine.

I was able to check-out and check-in an excel file without any fuss. Can someone confirm this please?

share|improve this answer
    
Hey Muhammedh, I was looking for answer to this also, works like a charm. Thank you for posting and sharing. –  user18922 Aug 14 '13 at 13:47
    
You are welcome @Zakart! –  Muhammedh Aug 26 '13 at 10:30

save the excel file as ".xls" instead of ".xlsx"

share|improve this answer
    
Don't think this is a suitable solution :(! –  Muhammedh Feb 24 at 15:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.