Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

We've recently upgraded from SharePoint 2007 to 2010 and we are trying to get the Excel Web Access web part to work.

Excel Services is running if that's required, the workbook location is configured to be trusted, and when linking a Workbook to the web part, this displays

enter image description here

The full message is below, even though a Workbook is selected.

To display a workbook in this Web Part, you must first select the workbook.

To select a workbook, open the tool pane, and then edit the Workbook property

Question: Does anyone have an idea of what is causing this?

It may be related, but if I try to open the Workbook in the Excel Web Access (not the web part) I receive this message.

enter image description here

I've tried to look this up and most things say to check permissions based on error messages, but there are no messages in the Event Viewer. This is similar to Excel Services 2010 Error - "The workbook cannot be opened." but none of the solutions work.

There is an Excel Services Proxy running and Office Web Apps is enabled on the site collection.

Any suggestions on how to fix this?

share|improve this question

2 Answers 2

Check that Excel Calculation Services is started. Central Admin > Application Management >Manage services on server

share|improve this answer

the problem is that the excel is to complex for showing..

try a simple excel sheet and it will work

share|improve this answer

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

    
Hi and welcome to SP.SE tdc. You could edit your answer, add additional info on what features of excel doesn't work. Is it lookup to other worksheets, calculations or other things that makes Excel Web App respond like this? Thank you! –  Benny Skogberg MCSA Sep 18 at 13:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.