Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I am publishing a a Content Type from a Content Type hub. This content type contains a Managed Metadata column. The column has a default value, set in the hub.

On a subscriber site, I set a library to use this content type, but I want to be able to set a different default value for the Managed Metadata column at the library level.

From the library, I turn off the read-only flag. I can now go into the managed metadata column and select a different default value. It seems like this should do what I want.

But it only partially works as expected. When I upload a document, the default value for the Managed Metadata field is as I specified from the library settings. However, if I use the "New Document" button, it uses the default as set in the hub.

Is there a way to get the "local" default to populate as desired in both cases?

share|improve this question

1 Answer 1

I have found a workaround for this issue.

If you create a new template and set the desired "local" default value on the Doc Property for that template, you can set the content type to use the "local" template under Advanced Settings for the content type.

This definitely works, but I am still interested in a more elegant solution.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.