Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I disabled the anonymous access in IIS 8 / Authentication hosting SharePoint 2013. Now when I browse to http://sharepoint13/ I get a "This page has not been shared with you". When I browse to http://sharepoint13/pages/default.aspx it works. I experience the same issue when using sharepoint web services.

Can anyone explain me why disabling anonymous authentication causes this?

share|improve this question
1  
You're disabling Anonymous authentication in IIS? Is the web application using claims authentication? If so, my understanding is that with claims IIS passes the users to SharePoint to handle the authentication. To do this, you require anonymous authentication at the IIS level. I'm not sure why /pages/default.aspx would work though. –  shufler Apr 17 '13 at 23:52
    
Yes I disabled it directly in IIS and I use claims. –  Max Melcher Apr 18 '13 at 12:01
    
You should turn anonymous authentication in IIS back on as this is required to support claims. Anonymous in IIS does not explicitly equate to anonymous in SharePoint. –  shufler Apr 21 '13 at 19:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.