Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

i have an infopath form on a sharepoint list. it works fine. i've added data connections to the list before. i've not worked on the form in a while, and just now realized that i'm no longer allowed to add data connections using the wizard, to a sharepoint list.

i get "The operation could not be complete" with no additional information.

i AM able to add a Field of lookup type to a sharepoint list, but that doesn't help me because it only surfaces the ID and Title fields and i need to be able to query the list connection using other parameters.

i looked in the sharepoint logs and couldn't see anything obvious.

any ideas how to get this functionality back??

enter image description here

share|improve this question
add comment

3 Answers

up vote 1 down vote accepted

Do you have root site for your site collection? It your site collection has only sub site then you need to create root site also to open sub site in InfoPath 2010.

share|improve this answer
    
this was the answer. i'd deleted it because i don't need a site there. –  April Drake Apr 17 '13 at 19:15
add comment

Try to create a root level site collection. It will work.

share|improve this answer
    
Can you please extend this answer, why will it work, and why is it not working as is? :) –  Robert Lindgren Jul 9 '13 at 7:25
add comment

You have not changed the proxy settings in IE right? Ensure you can navigate to your SP site using your default browser (IE e.g.)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.