Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

This is really weird as it seems so simple to me, but just won't work.

 myserver/site/lists/ExampleList/AllItems.aspx?ID=133

isn't this the basic url filter to only show that item?

it does work however if I use

 ?FilterName=ID&FilterMultiValue=133

but this just seems wrong to me as I am only filtering by the id (ya know...to send emails with link to the item/doc). am i missing something?

share|improve this question

2 Answers 2

up vote 2 down vote accepted

I think you are thinking of the new/edit/display forms which usually look like this:

dispform.aspx?ID=133
share|improve this answer
1  
right. this is totally correct...not sure what I was thinking. thanks though. –  Justin Apr 18 '13 at 21:44

AllItems.aspx is a view and as such it expects to display multiple items which is why the second approach works. That syntax creates a filter on the view based on the ID field and shows the ID you specify. This is the same thing that happens when you filter on a column from a view.

If you are looking to link directly to an item, the URL would be something like this :

myserver/site/lists/ExampleList/DispForm.aspx?ID=133

share|improve this answer
    
yep. i dunno what I was thinking. thanks –  Justin Apr 18 '13 at 21:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.