Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have a sql view that returns 449 records.

I have setup my external content type to point to this view and have implemented via SPD the read item and read list operations.

I have created the profile page and provisioned an external list.

The external list returns 449 records as expected.

I have configured a new content source in the search application to index the LOB source but it only ever indexes 21 records!

What am I missing here?

I have done this on two seperate farms now... have deleted an recreated everything several times.

Any help here would be much appreciated

Thanks in advance,

pete

share|improve this question

1 Answer 1

The most important in enabling External Content Type search is to create the Profile Page Site and than profile page for the ECT (http://msdn.microsoft.com/en-us/library/gg512148(v=office.14).aspx#confsps_part1_ExampleSearchingExtData).

It is through that page actually the you will be able to access the search results. Also do make sure your ECT has the Title properly setup and as well the Search account used for crawling has Read access to the Entity in the BDC.

Run Full-crawl on your Content Source afterwards.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.