Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

We have an new sharepoint 2013 site, Server Virtual and standalone , it has 12 gb ram. This sharepoint user interface extremely slow.

In Developer Dashboard we see each aspx page requests waiting about 6-7 second.

Aspx request waiting

sql execute details in aspx request

Have any idea ?

share|improve this question
    
what's your full system specifications and what have you installed on it so far. –  Muhammad Raja Apr 12 '13 at 11:00
    
on developer dashboard tumbnail.aspx waiting about 7000 ms, you can see call stack below; !enter image description here !enter image description here SqlCommand: 'proc_FetchDocForHttpGet' CommandType: StoredProcedure CommandTimeout: 0 Parameter: '@RETURN_VALUE' Type: Int Size: 0 Direction: ReturnValue Value: '' Parameter: '@DocSiteId' Type: UniqueIdentifier Size: 0 Direction: Input Value: '1e581f6c-2a2d-4df3-bb27-6425f6ae152f' Parameter: '@DocDirName' Type: NVarChar Size: 4000 Direction: Input Value: 'DivanHotel/PR2' P –  Sefer KILIÇ Apr 12 '13 at 13:42
    
Obviously your SQL communication is slow, There might very well be some bad configuration in SQL Server. How much memory is your SQL server instance using (in Task Manager)? And how much CPU? –  Robert Lindgren Apr 12 '13 at 13:55
    
using only 450 mb –  Sefer KILIÇ Apr 12 '13 at 13:56
    
sory you asked cpu: cpu using only between 0-2 –  Sefer KILIÇ Apr 12 '13 at 13:59

6 Answers 6

My problem solved! Have look at:

http://blog.blksthl.com/2013/05/15/sharepoint-2013-page-loads-takes-a-very-long-time/

turn off distributed cache:

enter image description here

Site loading time with it off:

enter image description here

site loading time with it on:

enter image description here

!!! From 6.10 seconds down to 79 ms

share|improve this answer
2  
While this may theoretically answer the question, we prefer inclusion of the essential parts of the answer here, and to provide the link for reference. See answer for general guidelines. And please don't add a sig. Oh, and don't plug your own blog with out adding a disclaimer - please see May I promote products or websites I am affiliated with here? for guidelines. –  SPDoctor May 16 '13 at 17:07
    
This worked for me too. What about the prod environment though is this distributed cache service broken? –  James Jun 7 '13 at 18:37
    
This was the perfect solution, could you please update the answer on the actual question as well as the link? –  MackieeE Jul 31 '13 at 8:19
    
I turned mine off, still terribly slow on new laptop VM with 16GB RAM and SSD. –  PeterX Mar 13 at 4:16
4  
Turning off Distributed Cache is NOT a fix. You will find some functionality will no longer be available without it, but likely in an unnoticed manner. Turning this off only means that you do not have enough memory assigned to the virtual machine. In fact a single-node SP2013 farm is almost completely a waste of time. I highly recommend at the very least adding an additional server to the farm to just run Distributed Cache, but ultimately two more, to split off Service Applications like Search, too. –  Ashley Steel Apr 3 at 20:08

For driving SP 2013 with only 12 GB of RAM I recommend that you stop the search from doing continous crawls, and to stop any services that you do not plan to use. Otherwise you will ned a bit more memory.

The search continous crawl uses a massive amount of system resources, so in a low performance environment, it should be turned of if it is not extremely necessary for your purposes.

Also make sure that the virtual machine is allowed to use more than one processor core in your VM environment settings (This got me once in Hyper-V)

share|improve this answer
1  
Most of sharepoint services (like search service) is already stopped and in performance monitor ram usage is only 5-6 gb. Let's check vm envrionment –  Sefer KILIÇ Apr 12 '13 at 11:17

Most likely because your machine doesn't have sufficient memory. SharePoint performance mostly depends on Hard disk and memory however SP 2013 is a memory beast, I don't think 12gb is enough if it's a single development server, check this article out,

Why SharePoint 2013 requires so much memory?

I installed SharePoint 2013 on a single box along with 6gb and all I was able to do is to create a single site collection and since then it stopped working.

Edit

Since the problem is only when you try to access SharePoint in browser, you should enable Developer Dash board and check what factor is taking most time while page loads.

Developer Dashboard in SharePoint 2013

Enable it using PowerShell,

$content = ([Microsoft.SharePoint.Administration.SPWebService]::ContentService)
$appsetting =$content.DeveloperDashboardSettings
$appsetting.DisplayLevel = [Microsoft.SharePoint.Administration.SPDeveloperDashboardLevel]::On
$appsetting.Update() 
share|improve this answer
    
In performance monitor ram usage is only 5-6 gb. There are not content on db, only empty sharepoint template. –  Sefer KILIÇ Apr 12 '13 at 11:15
    
@SeferKILIÇ you need to enable DD to monitor then –  Muhammad Raja Apr 12 '13 at 11:42
    
I see in DD , all aspx request waiting about 6000 ms, –  Sefer KILIÇ Apr 12 '13 at 13:12
    
On sql tab i saw sql request/response details and I think there is a sql server problem here . proc_FetchDocForHttpGet 3.525 ms DECLARE @DocPare 2.690 ms proc_GetTpWebMetaDataAndListMetaData 2.388 ms proc_GetWebMetainfo 1.747 ms –  Sefer KILIÇ Apr 12 '13 at 13:14
    
I got this problem with a fresh install of SharePoint 2013 on a single VM, using a backend SQL cluster. The SP server has 8 GB RAM and 8 cores available to it. It runs pretty lean using only 40% of the memory, so far. Still, I was looking at 6 second load times on the Home.aspx page. EVERY time. So I tried stopping the Distributed Cache service, and speed was back up... It's NOT a resource-problem... –  tplive Jan 23 at 12:42

We had this problem on our farm - same exact issue - 6 second delay for EVERY PAGE. Distributed Cache is very buggy in some versions and may need patching (we are now on CU4, planning for CU5) as well as TLC from Microsoft Premier support.

share|improve this answer
    
And did CU4 solve the problem at hand? –  Benny Skogberg MCSA Jul 17 at 12:27

Have you got any solutions installed in your farm? if yes, then please retract all of them and then check the behavior.

share|improve this answer

If you like to tune up the latency, I may recommend couple things.

  • Since SQL 2008, SQL supports 64 KB formatted partitions. If you may keep the database in a partition which is formatted as 64 KB, that will increase SharePoint 2013 performance directly.

  • On the hand, as default SQL databases increases size by 2 MB each time when needed. You can fix this number for certain amount, database will stop to increase the database size time to time to grow.

With only these two things there is a chance you may increase your SharePoint experience up to %30.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.