SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

In my Document Library named Lists/Documents, I have some corrupted items. I can see them and their properties in ListView, but I cannot edit or delete items.

This is not a Permission problem. Rather, the files do not exist in the Sharepoint file system.

In my listview

Can see in listview.

I can see properties in ViewForm

Can see properties

When I want to see them in Windows Explorer, they're not there (ex : v-3192xx.tif);

Can not see by windows explorer

When I want to delete or edit them:

Can not delete or edit

When I want to replace the file from my desktop using Windows Explorer: It says "file already exists", but I cannot replace it.

Giving error :"file name is too long or not valid"

Can not replace by windows explorer

share|improve this question

migrated from Apr 6 '13 at 17:59

This question came from our site for professional and enthusiast programmers.

Can you see the files in 'manage checked out files'?… – Nat Apr 1 '13 at 19:53
No can not see and "Require documents to be checked out before they can be edited" is NO. – Tufan Barış Yıldırım Apr 1 '13 at 23:38
You should check out SQL Server, maybe transaction log is full? – Tomas Voracek Apr 3 '13 at 20:13
No, server is new all disks and limitataions are have enough space. – Tufan Barış Yıldırım Apr 4 '13 at 12:13
up vote 2 down vote accepted

I don't know how i deleted files without deleting properties but; I deleted files from Sharepoint Database.AllDocs. And solved.

share|improve this answer
I've seen it happen when there is a file in AllDocs whose ScopeID value ends up not referencing any permission scope (because something went wrong while changing permissions). When that is the case, trying to access the manage permissions page will throw an error. – lgaud Apr 7 '13 at 12:57
@lgaud Yes! This is what the problem exactly is. – Tufan Barış Yıldırım Feb 1 '14 at 11:45

I have had a similar issue before, i believe it happend to be because of some illegal character in the name (the file was uploaded via windows explorer). I can't remember how I got rid of them, but I can think of two possible options I could have used. 1) Delete them with powershell 2) Mount the explorer view as a drive and delete the files from a command prompt.

share|improve this answer
as you see in question; I can not delete them with powershell (exception : file no found) can no see in explorer. – Tufan Barış Yıldırım Apr 4 '13 at 12:10

File is stored in SharePoint database, so as first thing I would check that. Check SQL Server logs for signs. Also, it can be caused by SQL log being full.

Other idea I have is creating simple app using MOSS object model to do some operation on file and if that fails, check the exception for more details.

share|improve this answer
all exeptions abouy this issue "File not found or Access denied" – Tufan Barış Yıldırım Apr 4 '13 at 12:11

Try to edit one of the items and search for item name in the SharePoint ULS log. The problem will be logged there. If it wont make sense please share related part of the ULS log here.

You can find ULS log in Program Files\Common files\Microsoft Shared\Web Server Extensions\14\LOGS

share|improve this answer
all exeptions about this issue "File not found or Access denied" – Tufan Barış Yıldırım Apr 4 '13 at 12:12
please share parts of ULS log from just after you get an exception to 2 minutes after that – Kambiz Shahim Apr 4 '13 at 12:30

change filenames, and make them shorter. u can have only 255 charakters in names(including path!), and sharepoint allow some illegal charaters for system

share|improve this answer
I can not change file names. Because I can no edit or see file. can see only properties. – Tufan Barış Yıldırım Apr 4 '13 at 12:09

Do you have file versioning enabled in that Document Library ?

If yes, then may be it is Not worth telling this for a solution , but i have read somewhere that disabling the Document library version may fix this issue..

Why don't you give it a try ??

Let me if this solve your problem ?


share|improve this answer
versioning is enabled, but i can not use "Version history" dialog because of "File not found" error. – Tufan Barış Yıldırım Apr 6 '13 at 11:35

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.