Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Our sharepoint installation used to run so that when you were logged in to the computer via active directory going to the sharepoint site it logged you in automatically. This seemed to happen only if you went to the site using the hostname. If you use a FQDN you are always prompted to log in. Is there a way to make set up sharepoint to always log someone in if they are logged into the machine using their AD credentials?

share|improve this question
    
Are you talking about accessing a SharePoint site that is running on the same box that you are logged into? –  Dave Wise Apr 5 '13 at 15:08
    
No. The sharepoint box sits on the local network. Everyone has to login to there machines using AD credentials. Sharepoint is our intranet. So ideally folks shouldn't have to login to it once they've logged into their machines. –  LoneWolfPR Apr 5 '13 at 15:13
add comment

1 Answer

This is almost certainly a browser configuration issue, not a SharePoint issue and to handle this most companies create a policy for IE that automatically adds "*.companydomain.com" to their local Intranet zone which, by default, passes local credentials to any site on that domain. Some companies go further and put this in the Trusted Sites zone instead, though that one does not pass credentials by default (no idea why those are the defaults but they are). This, of course, assumes that you are using a domain like 'sharepoint.companydomain.com'. If you are using a FQDN that does not include the company domain (like 'sharepoint.local') then you have to add that to your browser security settings as well. Though, in this case it would probably be better to simply add "*.local" instead of the specific domain name.

To test this, you can manually add the current Sharepoint FQDN to your Intranet Zone simply by going to Tools - Internet Options - Security - Local Intranet - Sites - Advanced and adding the FQDN. You might have to restart your browser but that should fix the issue. If it does, then you will want to work with whoever maintains your corporate Windows policies to have them push that setting out to everyone in the company.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.