Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

This question already has an answer here:

Is there a way to make certain web parts visible to selected users or groups?

Thanks in advance

Steve

share|improve this question
add comment

marked as duplicate by Muhammad Raja, John Chapman, PirateEric, RJ Cuthbertson, Robert Lindgren Jun 25 '13 at 9:32

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

3 Answers

Yes you can. Just fix the target Audiences. follow the method.

First of All make sure that You enabled option of Audience targeting settings.

If Not then Follow this steps to enable it Select the list or library that contains the item that you want to target. On the list toolbar, click Settings, and then click List Settings or Document Library Settings. Under General Settings, click Audience targeting settings. Select the Enable audience targeting check box.

1.Select the list or library that contains the item that you want to target. 2.On the list toolbar, click Settings, and then click List Settings or Document Library Settings. 3.Under General Settings, click Audience targeting settings. 4.Select the Enable audience targeting check box.

After this check for the option of Target Audiences in your web part .

Thanks.

share|improve this answer
    
Hi Prasath,Thank you for your reply. However I do not have the Audience targeting settings option when i open the list settings..... Any thoughts on this? –  Steve.C Apr 5 '13 at 11:36
    
Did you login as admin user? –  Prasath S Apr 5 '13 at 11:52
    
I have Edited my post above posting the sutable link. –  Prasath S Apr 5 '13 at 11:55
    
@ Prasath - Yep. –  Steve.C Apr 5 '13 at 11:55
    
I am sorry, but I do not see any link... –  Steve.C Apr 5 '13 at 12:06
show 1 more comment

Go to Site Contents > select the web parts settings

Under the Permission and Management select Permissions for this list.

If Inheriting is enabled, select Stop inheriting in the ribbon. Otherwise select Grant Permission.

Then enter the permissions to the users/groups.

share|improve this answer
add comment

Yes you can. Just fix the target Audiences. follow the method.

First of All make sure that You enabled option of Audience targeting settings.

If Not then Follow this steps to enable it Select the list or library that contains the item that you want to target. On the list toolbar, click Settings, and then click List Settings or Document Library Settings. Under General Settings, click Audience targeting settings. Select the Enable audience targeting check box.

1.Select the list or library that contains the item that you want to target. 2.On the list toolbar, click Settings, and then click List Settings or Document Library Settings. 3.Under General Settings, click Audience targeting settings. 4.Select the Enable audience targeting check box.

After this check for the option of Target Audiences in your web part .

http://www.share pointboost.com/blog/how-to-configure-the-target-audience-for-a-web-part-in-share point-2010-sites/

Thanks.

share|improve this answer
    
I have come across another problem... I do not have the SharePoint Server Publishing Infrastructure” feature options mentioned in the guide.. Am I totally missing something here? –  Steve.C Apr 5 '13 at 12:16
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.