Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I am using Sharepoint 2010 and when users click on an .xlsx document in a document library it says the following:

"The workbook cannot be opened because it contains the following features that are not supported by Excel in the browser..."

"Would you like to try and open this file in Excel"

It is clear to me from the error that the browser wont support certain features of Excel in the browser. Question is, how to best deal with this to make a nice experience for the user?

The only way I can think of is to have a special rule to tell all Excel documents to open in Excel as opposed to the browser. Does anybody know how to do this or have any better approaches?

share|improve this question

3 Answers 3

up vote 2 down vote accepted

You can configure the default-open behavior of browser enabled documents in the list settings. See http://technet.microsoft.com/en-us/library/ee837425(v=office.14).aspx

If you don't want miss excel service feature, you might also think of providing a dedicated page where a web part displays your library and another web part (for example a content editor) explaining to the users the excel services limitations.

Limitations are clearly documented by MS http://msdn.microsoft.com/en-us/library/ff595319%28v=office.14%29.aspx.

share|improve this answer

You can define in the library settings whether or not to open documents in the browser or the client application. The default is set on the server, but you can overrule that at the library level. Since Excel Services cannot open workbooks with data validation, graphic object or VBA, many Excel files with basic functionality simply won't load in the browser.

share|improve this answer

This error occurs when you have slicers in the frame boxes provided automatically by Excel Pivot Table, when creating a chart or table. Click the chart, Format, Selection Pane, and remove all rectangles, eg. Rectangle 1, 2 ect. Ignore those that excel creates right away after you delete the first. When you have a table, not a chart, click the drawing box around the slicers, and find Selection Pane there.

This link explains this in detail: http://powerpivotgeek.com/2010/05/21/unsupported-features-warning-message-from-xcel-services/

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.