Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

When I click on the Linked Item it opens up an InfoPath form in read mode.
But no ability to switch to different views (pages) in my form is allowed unless I go to edit mode.

Why do the buttons disappear while in Read mode.
Is this a default behavior? Can it be changed? How do I edit the display form to show the buttons?

enter image description here

enter image description here

share|improve this question
add comment

2 Answers

up vote 2 down vote accepted

I ran into the same problem but I was using the InfoPath Web Part in a custom page so this solution may not work.

Instead of marking the InfoPath Web Part as read only (in the edit web part UI) I created a new view of the form and marked the view as read only. Then you change the web part to use the read only view.

Now you do need to make sure the views that the buttons switch to are also read only otherwise people will be able to edit them.

share|improve this answer
    
Thanks Ryan I'm in business. –  Ben_Coding Mar 29 '13 at 20:27
add comment

When using picture buttons, head to the picture button properties and deselect the option that says 'Hide picture button in read-only views'.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.