Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I am trying to accomplish the following scenario.

In my document library I want the top level view to use a view called "Folders" where it only shows two columns. Upon clicking a folder in the view I would like the default view to be the standard "All Documents View".

I tried setting the views to user per location settings so that the second level the "folders" view is not available and the "All Documents" view is the default. I have also set this to stop inheriting from the parent.

After all this it seems to have no effect on the actual navigation, only what views are available from the drop down.

I have found a few things suggesting this may be a bug, can anyone shed any light to confirm this or if there is a work around?

share|improve this question
    
We have the same issue - support.microsoft.com/kb/2806007 confirm this as an issue but typical of MS do not say it is a bug but send you round the houses to arrive at the same non working feature you started with Grrrrrrrrrr :-( –  user15950 Mar 28 '13 at 11:16

1 Answer 1

Someone named Sally at technet social came up with a workaround using content types but it would force the user to use the metadata nav instead of the right-side view they are accustomed to...

  1. Create a document library in the SharePoint site.
  2. Create a new content type from Site Settings > Galleries > Site content types. Here we create a custom content types parented by document set.
  3. Go to the document library, click Library Settings, Advanced settings, configure to allow management of Content Types.
  4. Add the custom content type.
  5. Go to document library, and create some new document with the custom content type.
  6. Create a custom view in the library.
  7. Go to Library settings > Metadata navigation settings, add “Content type” to Hierarchy Fields.
  8. Go to per-location view settings, point to the custom content type from the left pane, set the custom view as the View available at this location.
  9. Save the settings.
  10. Navigation to the content type in the Metadata Navigation on the left, and you can see the default view is the custom view.

For your reference, you may also refer to this article: http://blog.vossers.com/2009/12/27/per-location-view-settings-in-sharepoint-2010-views-per-content-type/

If you are okay with the metadata navigation, then this may be the solution for you...

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.