Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I build SP 2010 project through VS 2010. On deploying through visual studio, I get following error:

Error occurred in deployment step 'Activate Features': Access is denied.

Any idea, what's wrong ??

share|improve this question
    
have you opened vs2010 as administrator..? –  Sravan Mar 26 '13 at 13:05
add comment

2 Answers

try this..

go to Central Administration -> Application Management -> Configure quota and locks

in that Site Lock Information Section.

select Lock Status for this site -> Not locked

Hope it helps...

share|improve this answer
    
I checked, its already Not locked. –  SPBeginer Mar 26 '13 at 13:45
    
also check database is in readonly and site collection administrator.. –  Hitesh Chandegara Mar 26 '13 at 13:54
add comment

run this script in powershell, it has todo with editing you web.config file.

$cs = [Microsoft.SharePoint.Administration.SPWebService]::ContentService 
$cs.RemoteAdministratorAccessDenied = $false  
$cs.Update()

before updating the web.config programmatically, the 'Remote Administrator Access Denied' flag from the content service has to be switched off, otherwise, the SharePoint server spontaneously throws this misleading 'Access Denied' error message

http://software-smith.blogspot.co.uk/2011/04/writing-programmatically-to-webconfig.html

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.