Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I want to use more then 1 query param for custom list form. So, this is XML definition: _layouts/MyPage.aspx?param1=x&param2=y

When custom form is called for new listitem it sending request like this:

_layouts/MyPage.aspx?param1=x&param2=y

My thoughts are, that querystring being encoded before redirecting from standard SP list form to my custom. I tried also CDATA - didn't work.

share|improve this question
    
for now, I concat all my params into 1, but I hope its not the best you could do: /MyPage.aspx?aggregatorparam=param1-x.param2-y –  dbardakov Mar 27 '13 at 7:03
add comment

1 Answer 1

An ampersand in XML must be escaped as &, so your software is behaving quite correctly. When the XML is parsed by the recipient, assuming a correct XML parser, it will translate the escaped & back to &.

share|improve this answer
    
you are right, but I don't want to customize standard SP listform.aspx that works with all site list forms. –  dbardakov Mar 27 '13 at 7:13
    
The problem is that the ampersand is being XML encoded for storage by SharePoint, but SharePoint does NOT properly DECODE the & back into a an ampersand, instead using the & as part of the resulting query string. –  Zarepheth Oct 27 '13 at 18:56
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.