Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I create a new site collection called site1 through user1 who is also farm admin.

When I search something in site1, it brings all results i.e. not only from this site but other site collections also (because I am using custom search scope "All Sites")

I created another AD user called user2

I gave READ permissions to user2 in site1 by adding it into VISITORS group.

Then I logged into site1 as user2 and searched something but it is only showing results from other site collections and not this current site1.

I then added user2 in site1 SITE OWNER group but still same problem. It is not showing results from current site collection.

Why is that? That user2 is the owner of site1 but still no results!? While in case of user1 it works who is also farm admin.

share|improve this question
    
Ok I fixed it. I did a full crawl again and now user2 can also search. So that means any time I change user permissions in site, I will have to do full crawl for changes to take effect? –  Frank Martin Mar 26 '13 at 10:32

1 Answer 1

up vote 0 down vote accepted

Ok I fixed it. I did a full crawl again and now user2 can also search.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.