SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I recently started to develop Sharepoint 2013 on my office 365 account.

The problem is that remote event receivers which I attach to deploying application do not work.

I mean that they should listen to particular events and then perform action. And it seems that they even do not listen to anything – they don't fire anytime.

share|improve this question

Visual Studio by default creates an elements.xml file to deploy Remote Event Receiver. Which mean it is actually deployed to App web (web cretaed specifically for your SharePoint application), not the Host web (where your actual content is).

share|improve this answer

Please read the following two full step-by-step articles (with information about service bus configuration) about Remote Event Recevers in SharePoint Online:

1) Creating and Debugging of Remote Event Receivers for SharePoint Online http://blog.virtosoftware.com/2014/12/creating-and-debugging-of-remote-event.html

2) Adding Remote Event Receivers to list on Host web + Debugging http://blog.virtosoftware.com/2015/01/adding-remote-event-receivers-to-list.html

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.