Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

When doing development in SP2010, I used to be able to edit files in _layouts/MySolution/... directly in 14 folder and see changes immediately (.js, .css files). That reduced time a lot while developing, and I could copy files back to solution after I am finished.

However, when I modify files in 15 folder in SP2013, SharePoint seems not to pick the changes immediately. It does so after recycling application pool, as well as after some period of time. So I suspect some sort of caching, that was not present in SP2010.

So the question - where is it and how do I turn it off for dev environment?

Note: it is not browser caching. I tried appending .css?QueryStringToForceCacheReload, as well as opening file in browser directly, Ctrl+F5 etc. Recycling app pool does help, but the whole point is not to wait for app pool recycling.

share|improve this question
add comment

3 Answers 3

Configuring object cache settings

The object cache settings can be configured at the site collection level in the user interface by a site collection administrator, and is on by default. The maximum cache size can be configured at the Web application level on the front-end Web server to place a restriction on the maximum amount of memory that the cache will use for all site collections. For example, individual site collections might have the object cache set at 100 MB, while the Web application might be set at 1 GB. In this case, no more than 1 GB of memory will be used by all the caches on the server.

  1. Verify that you have the following administrative credentials: You must be a member of the Administrators group on the local computer to configure the object cache settings.

  2. Click Start, point to Administrative Tools, and then click Internet Information Services (IIS) Manager.

  3. In Internet Information Services (IIS) Manager, in the Connections pane, click the plus sign (+) next to the server name that contains the Web application, and then click the plus sign next to Sites to view the Web application or applications that have been created.

  4. Right-click the name of the Web application for which you want to configure the disk-based cache, and then click Explore. Windows Explorer opens, with the directories for the selected Web application listed.

  5. Right-click web.config, and then click Open.

  6. If the Windows dialog box appears, select Select a program from a list of installed programs, and then click OK.

  7. In the Open With dialog box, click Notepad, and then click OK.

  8. In the Web.config Notepad file, find the following line:

  9. To change the size of the cache, type a new number for maxSize. The size is expressed in megabytes (MB), and 100 MB is the default.

  10. Save the Notepad file, and then close it.

Blob chacing

By default, the disk-based BLOB cache is off and must be enabled on the front-end Web server if you want to use it. Use the following procedure to configure disk-based cache settings for a Web application. Important:

Before you make changes to the web.config file, make a copy of it by using a different name (for example, web.config1), so that if a mistake is made in the file, you can restore the original file.

To configure BLOB cache settings

  1. Verify that you have the following administrative credentials: You must be a member of the Administrators group on the local computer to configure the BLOB cache settings.

  2. Click Start, point to Administrative Tools, and then click Internet Information Services (IIS) Manager.

  3. In Internet Information Services (IIS) Manager, in the Connections pane, click the plus sign (+) next to the server name that contains the Web application, and then click the plus sign next to Sites to view the Web application or applications that have been created.

  4. Right-click the name of the Web application for which you want to configure the disk-based cache, and then click Explore. Windows Explorer opens, with the directories for the selected Web application listed.

  5. Right-click web.config, and then click Open.

  6. If the Windows dialog box appears, select Select a program from a list of installed programs, and then click OK.

  7. In the Open With dialog box, click Notepad, and then click OK.

  8. In the web.config Notepad file, find the following line:

save and exit, now make your changes and reload the page!

http://technet.microsoft.com/en-gb/library/cc770229(v=office.14).aspx

share|improve this answer
    
That doesn't help. Blob caching is not enabled (enabled="false") and object cache - "To use the object cache, you must be using the Publishing feature on your site." - I am not using publishing feature. And anyway, I tried setting maxSize="0" and iisreset, it did nothing. –  Voyta Mar 25 '13 at 15:47
add comment

Why don't you use for example cks:dev in visual studio and set the property Auto Copy to SharePoint Root to true of the project. This way you get full control, anyway and I don't have any problems with something getting cached.

share|improve this answer
add comment

Could this be the new Minimal Download Strategy at play? It's a feature that is enabled by default and helps save bandwidth by not trying to download unnecessary files.

In SharePoint 2013 Minimal Download Strategy is enabled by default and can be disabled where necessary on a per SPWeb basis using EnableMinimalDownload property and settings its value to False.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.