SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I go to "site permissions" I can see groups that have some permissions and modify their permissions level, but groups without any permissions set do not appear in the list. I can see them in "People and groups" but even if I edit their properties I don't see a way to add permissions. I can delete them and recreate them with permissions, but there has to be a way to just add permissions to a group without any right?

share|improve this question
up vote 0 down vote accepted

I am assuming that you are setting permissions for a subsite that has chosen not to inherit permissions from the parent site. In which case, merely go to the permissions for the subsite and Add the group that you want to have access to the site and then grant it the permission that you want for the site.

share|improve this answer
How does one accomplish that last part through the sharepoint? I can add users to a group, but the "site permissions" page only shows groups that already have some relevant permissions. How do I add permissions to a group that has none already? – Stephen Lujan Mar 21 '13 at 18:10
go to Site Permissions for the site and click on Grant Permissions in the ribbon. Type the group name in the Users/Groups box and click 'Check names' to make sure it finds the right one. Then click G'Grant use Permission directly' in the box below it. You probably want to uncheck the 'Send E-Mail' box to avoid spam. – Dave Wise Mar 21 '13 at 18:20
For some fool reason I thought you could only add users in that dialogue and not groups. It even says otherwise and I missed it. – Stephen Lujan Mar 22 '13 at 14:27
This option is hidden underneath the "Options" section on Sharepoint 2013, after the message you might want to send to people. I overlooked it half a dozen times. – Jason Bray Feb 12 at 19:15

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.