Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I'm using the Windows SharePoint Services adapter and I'm receiving the following error message on the BizTalk 2010 Server:

The Windows SharePoint Services adapter runtime does not have permissions to invoke the adapter Web service. In order to fix this issue, you have to add the DEVELOPMENT\BizTalkHostSRV Windows account to the "SharePoint Enabled Hosts" Windows group on the Windows SharePoint Services machine.

I have added the DEVELOPMENT\BizTalkHostSRV account to the SharePoint Enabled Host in AD and also did the same as a windows group to try it out but no joy.

We have a multi SharePoint 2010 environment setup what I have found is that there is a problem when the web application Authentication Provider is running as Claims Based Authentication, if you re-configure your SharePoint Web Application to use Windows Authentication everything works fine.

My queation is, how do you get this working with Claims Based Authentication?? without the error message appearing??? I can't find any solution anywhere.

share|improve this question

migrated from stackoverflow.com Mar 19 '13 at 20:53

This question came from our site for professional and enthusiast programmers.

    
Dips - does BizTalk Server 2010 support Claims Based Auth? –  Nick Heppleston Mar 19 '13 at 9:46
add comment

1 Answer 1

In order to fix this issue, you have to add the DEVELOPMENT\BizTalkHost Windows account to the "SharePoint Enabled Hosts" Windows group on the Windows SharePoint Services machine. This operation will allow BizTalk host instances running under DEVELOPMENT\BizTalkHost Windows account to invoke the adapter Web service in order to send and receive messages to or from SharePoint sites. The group membership will not take effect until you restart the BizTalk host instance.

Basically, this error is caused by the fact that when you enable the SharePoint Services BizTalk adapter, it creates a local security group on the server called "SharePoint Enabled Hosts". The account that BizTalk is running under must be a member of this group.

http://practicalsharepoint.blogspot.co.uk/2012/07/windows-sharepoint-services-adapter.html

make sure your group "SharePoint Enabled Hosts" is a local group!

also have you done:

1.Go to your SharePoint site, probably http:///sites/ or http:///

  1. Go to Site Settings

  2. Go to Site Administration

  3. Click on Manage site groups

  4. Click on Contributors

  5. Add Members...

  6. Add \Sharepoint Enabled Hosts

2.Now from Administrative Tools -> Computer Management, add \ account to "Sharepoint Enabled Hosts" group

3.Restart BizTalk host instance from the Admin MMC

http://blogs.msdn.com/b/ahamza/archive/2005/07/29/wssadapterquestions.aspx

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.