SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Great site!!

I've configured my new SP2010 MySite to send me email alerts for all changes or additions to my MySite profile. However I'm not receiving them nor are any of my users.

Am I missing something really simple here? lol

Thanks All!

share|improve this question
Can you tell me where you configured this notification? I'm not aware of any alerts tied to changes made to the user profile. Since the profile can only be edited by the user, an administrator, or a scheduled synchronization task I'm not sure how alerts would be applicable. The email notifications shown on the Edit Profile page refer to notes that were left, when you are added as a colleague, or suggestions for new colleagues and keywords. Outgoing mail configuration should satisfy those requirements. – Mike Oryszak Oct 14 '10 at 0:28
Hi Mike, I am referring the notifications configured in the Edit Profile page like "Notify me when someone leaves a note on my profile.". Further information; My SharePoint site itself has no problem delivering alerts to end users who opt into them, it is only the SharePoint/My site that I'm having trouble with. I think the issue lies in the section below? "My Site E-mail Notifications Please specify a string which looks like an e-mail address. This will be used as sender's e-mail address for My Site e-mail notifications. This need not be a real monitored e-mail address." – Anonymous Oct 14 '10 at 15:52

Guys, the solution is laughably simple. In the MySite Web Application in the "Setup My Sites" section there is a field at the very bottom called "String to be used as sender's e-mail address:"

In that field I specified that the service use the same email address that is used to deliver all outgoing mail from SharePoint. ""

Turns out SharePoint didn't like that.

I, on a whim... changed that field to "" and the alerts have been working fine ever since.

In my defense the field where you specify this address was worded in a slightly confusing manner.

Thanks for all the support. Hope this helps someone in the future!

share|improve this answer

have you configured outgoing mails on your Central Administration?

share|improve this answer
Hi Anders, thanks for your response. Outgoing emails are configured and working as I have received alerts for document libraries, lists, etc. I think I may have stumbled onto the issue. I had not filled in the MySite Email Notifications Sender address. I populaded the field with the same account that is currently sending alerts from the Site Collection. Now I need to have someone leave a comment on my MySite profile to see if it works! Thanks! – Anonymous Oct 14 '10 at 15:57

Have you enabled the Activity Feed job in central admin?

share|improve this answer

This SharePoint alert troubleshooting guide should help

SharePoint alert troubleshooting guide

share|improve this answer

In CA, user Profiles – Activity Feed Job is running & outgoing email properly configure.

& In CA Application Management > Manage service applications. In the list of service applications, select your User Profile Service Application. Under My Site Settings > Setup My Sites, is the My Site E-mail Notifications field filled in with an email address given.

still when someone leaves a note on my profile/other user profile, an email alerts for all changes not receiving.

Any Idea?

share|improve this answer

Abhay, I don't know enough to comment on that piece.

Is your MySite hosted on the same Web Application as your main Team Site? SharePoint -80 ?

If not, verify that you have configured Outbound mail for the Web Application that hosts your MySite.

That being configured correctly in combination with a proper My Site E-mail Notifications address (without using quotes) should yeild positive results.

If that still doesn't do the trick then it may very well be your Mail Server.


share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.