Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I am trying to change the Site Collection administrator for a site collection, in Central Admin. under Site Collection Administrators.

When I select a new user from the lookup I get the "Error. An unexpected error has occurred." and it does not enter the new user into the field.

Basically I am trying to do this because the SP administrator before me set up Alerts for SP 2010 to go to his Gmail....sooo yeah. I am trying to change this account so the alerts are being sent to the Administrator rather than a Gmail. I tried simply changing the email for that user from his Gmail to the Admin email, however, when I view the site collection the email has not changed....is there a way to refresh this?

Thanks a ton! Tudor

share|improve this question
    
Did you change the email address on the user account associated with the site collection or on his user account in the user profile service? –  Dave Wise Mar 19 '13 at 18:27
    
First I tried just changing the email but that did not update in the Site Collection. So when I view the Site Collection details I cannot see the updated email. So then I am trying to just change the user account to see if that works, and that is when I get the error... –  Tudor Hofnar Mar 19 '13 at 18:31
    
If I got to the Manage User Profiles, I don't even have that user with the Gmail password in the list of profiles.. –  Tudor Hofnar Mar 19 '13 at 18:33
    
find the actual error in 14/LOGS and it should point you to what is really going wrong –  Dave Wise Mar 19 '13 at 18:35
    
Looking up the error by correlation ID in the LOGS gives something like this "System.InvalidOperationException: Namespace prefix 'xsd' is not defined." any idea? I have tried setting my browser to IE 8 standards but still getting the same error... –  Tudor Hofnar Mar 19 '13 at 19:01

1 Answer 1

up vote 0 down vote accepted

Refer to comments for original post to find out the resolution.

"Nevermind, I fixed it. I had to change to IE 8 Standards on the server not my local machine, my mistake."

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.